summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 13:45:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 14:00:32 +0100
commit1cdd9f0e8a3235cdb4f56f8d0ced569cba852079 (patch)
tree76a7bbf2ee396e267f872e4f89faf4ed4a0c13a7 /gnu
parentd4a255a48451f1899a0ebd1d17db0d200a3704b4 (diff)
downloadpatches-1cdd9f0e8a3235cdb4f56f8d0ced569cba852079.tar
patches-1cdd9f0e8a3235cdb4f56f8d0ced569cba852079.tar.gz
gnu: Add r-ldheatmap.
* gnu/packages/cran.scm (r-ldheatmap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b6fe53998b..4d7f68bbee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12579,3 +12579,28 @@ random effects, including spatial effects in field trials and pedigree
effects. It is applicable to backcrosses, doubled haploids, recombinant
inbred lines, F2 intercrosses, and association mapping populations.")
(license license:gpl2)))
+
+(define-public r-ldheatmap
+ (package
+ (name "r-ldheatmap")
+ (version "0.99-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "LDheatmap" version))
+ (sha256
+ (base32
+ "0il3g3n3bzv74lz7dlhyiwc2x2417v6yhx2g47pahxdzqa09kf4s"))))
+ (properties `((upstream-name . "LDheatmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-genetics" ,r-genetics)
+ ("r-snpstats" ,r-snpstats)))
+ (home-page "http://stat.sfu.ca/statgen/research/ldheatmap.html")
+ (synopsis "Graphical display of pairwise linkage disequilibria between SNPs")
+ (description
+ "This package provides tools to produce a graphical display, as a heat
+map, of measures of pairwise linkage disequilibria between SNPs. Users may
+optionally include the physical locations or genetic map distances of each SNP
+on the plot.")
+ (license license:gpl3)))