summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-27 21:41:58 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-31 23:32:47 +0200
commitf125c5a5ea03d53749f45d310694b79241d5888d (patch)
treee30791ba6b184d5a0ff2e35dfd3cff79258930a8 /gnu
parent7a352f76cfed0236eadf507debe1059f256653a4 (diff)
downloadpatches-f125c5a5ea03d53749f45d310694b79241d5888d.tar
patches-f125c5a5ea03d53749f45d310694b79241d5888d.tar.gz
gnu: emacs-zones: silence byte-compiler.
* gnu/packages/patches/emacs-zones-called-interactively.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm5
-rw-r--r--gnu/packages/patches/emacs-zones-called-interactively.patch43
3 files changed, 48 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e32b0298e1..45598d4e14 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -745,6 +745,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
+ %D%/packages/patches/emacs-zones-called-interactively.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \
%D%/packages/patches/eudev-rules-directory.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df5e2cf21e..1e8d703ce3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6037,7 +6037,10 @@ customizable by the user.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))))
+ "0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))
+ (patches
+ (search-patches
+ "emacs-zones-called-interactively.patch"))))
(build-system emacs-build-system)
(home-page "https://www.emacswiki.org/emacs/Zones")
(synopsis "Define and act on multiple zones of buffer text")
diff --git a/gnu/packages/patches/emacs-zones-called-interactively.patch b/gnu/packages/patches/emacs-zones-called-interactively.patch
new file mode 100644
index 0000000000..b60f390a7e
--- /dev/null
+++ b/gnu/packages/patches/emacs-zones-called-interactively.patch
@@ -0,0 +1,43 @@
+From fb56fbb706804215ef9af0cc575db97c373046c6 Mon Sep 17 00:00:00 2001
+From: Brian Leung <bkleung89@gmail.com>
+Date: Sun, 17 Mar 2019 01:32:04 +0100
+Subject: [PATCH] This patch silences the byte-compiler.
+
+---
+ zones.el | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/zones.el b/zones.el
+index 1bf94f0..94fa9a6 100644
+--- a/zones.el
++++ b/zones.el
+@@ -1031,7 +1031,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+- (zz-narrow-advice (interactive-p)))
++ (zz-narrow-advice (called-interactively-p)))
+
+ (defadvice narrow-to-defun (after zz-add-zone--defun activate)
+ "Push the defun limits to the current `zz-izones-var'.
+@@ -1039,7 +1039,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+- (zz-narrow-advice (interactive-p)))
++ (zz-narrow-advice (called-interactively-p)))
+
+ ;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
+ ;;
+@@ -1049,7 +1049,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+
+ This is a destructive operation. The list structure of the variable
+ value can be modified."
+- (zz-narrow-advice (interactive-p)))
++ (zz-narrow-advice (called-interactively-p)))
+
+ ;;(@* "General Commands")
+
+--
+2.21.0
+