summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:48:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:29 +0300
commitec38b3954da9143fff24352ecab048c325046785 (patch)
treecb696147d443db4122da76868b6b91d6d32f0b81 /gnu
parentf4e2d9ee6cf49ae7a9ff9a084517c274ea791955 (diff)
downloadpatches-ec38b3954da9143fff24352ecab048c325046785.tar
patches-ec38b3954da9143fff24352ecab048c325046785.tar.gz
gnu: Add perl-string-escape.
* gnu/packages/perl.scm (perl-string-escape): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 07cbce2d73..056acbb71f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6915,6 +6915,28 @@ run from within a source-controlled directory.")
CamelCase and back again.")
(license (package-license perl))))
+(define-public perl-string-escape
+ (package
+ (name "perl-string-escape")
+ (version "2010.002")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/EV/EVO/String-Escape-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12ls7f7847i4qcikkp3skwraqvjphjiv2zxfhl5d49326f5myr7x"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/String-Escape/")
+ (synopsis "Backslash escapes, quoted phrase, word elision, etc.")
+ (description "This module provides a flexible calling interface to some
+frequently-performed string conversion functions, including applying and
+expanding standard C/Unix-style backslash escapes like \n and \t, wrapping and
+removing double-quotes, and truncating to fit within a desired length.")
+ (license (package-license perl))))
+
(define-public perl-string-rewriteprefix
(package
(name "perl-string-rewriteprefix")