summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-06 03:14:17 -0500
committerLeo Famulari <leo@famulari.name>2017-01-06 03:19:40 -0500
commite50d5b8c9d948a2aa08c69aaa2e4a778387ed944 (patch)
treec704a821f1332dc4aa933946b492fc921d3858b6 /gnu
parente0c32fc817fcdb5abe7d4ad82a99b749d509d761 (diff)
downloadpatches-e50d5b8c9d948a2aa08c69aaa2e4a778387ed944.tar
patches-e50d5b8c9d948a2aa08c69aaa2e4a778387ed944.tar.gz
gnu: khal: Disable failing tests.
* gnu/packages/patches/khal-disable-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/calendar.scm (khal): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/calendar.scm1
-rw-r--r--gnu/packages/patches/khal-disable-failing-tests.patch33
3 files changed, 35 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2e714ac28c..2fbb01fb2e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -642,6 +642,7 @@ dist_patch_DATA = \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/jq-CVE-2015-8863.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
+ %D%/packages/patches/khal-disable-failing-tests.patch \
%D%/packages/patches/khmer-use-libraries.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 447dcd698e..70bf8f9573 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -88,6 +88,7 @@ data units.")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
+ (patches (search-patches "khal-disable-failing-tests.patch"))
(sha256
(base32
"03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
diff --git a/gnu/packages/patches/khal-disable-failing-tests.patch b/gnu/packages/patches/khal-disable-failing-tests.patch
new file mode 100644
index 0000000000..e2c65df8ce
--- /dev/null
+++ b/gnu/packages/patches/khal-disable-failing-tests.patch
@@ -0,0 +1,33 @@
+Disable some tests that are known to fail:
+
+https://github.com/pimutils/khal/issues/546
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844081
+
+diff --git a/tests/khalendar_test.py b/tests/khalendar_test.py
+index fd8dcc6..17732bf 100644
+--- a/tests/khalendar_test.py
++++ b/tests/khalendar_test.py
+@@ -65,6 +65,7 @@ class TestCalendar(object):
+ else:
+ mtimes[cal] = mtime
+
++ @pytest.mark.xfail
+ def test_db_needs_update(self, coll_vdirs):
+ coll, vdirs = coll_vdirs
+
+@@ -321,6 +322,7 @@ class TestDbCreation(object):
+ CalendarCollection(calendars, dbpath=dbpath, locale=aux.locale)
+
+
++@pytest.mark.xfail
+ def test_default_calendar(coll_vdirs):
+ """test if an update to the vdir is detected by the CalendarCollection"""
+ coll, vdirs = coll_vdirs
+@@ -341,6 +343,7 @@ def test_default_calendar(coll_vdirs):
+ assert len(list(coll.get_events_on(today))) == 0
+
+
++@pytest.mark.xfail
+ def test_only_update_old_event(coll_vdirs, monkeypatch):
+ coll, vdirs = coll_vdirs
+