summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-09 14:56:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-11 17:11:41 +0200
commitddb5dc08a738d9f6611c710da499363d0e8f9977 (patch)
tree8697fef12d9ef095d1468f823da286f45e026a22 /gnu
parente70771f08e14f12a4767477a519f679465748f47 (diff)
downloadpatches-ddb5dc08a738d9f6611c710da499363d0e8f9977.tar
patches-ddb5dc08a738d9f6611c710da499363d0e8f9977.tar.gz
gnu: Add ocaml-gsl-1.
* gnu/packages/ocaml.scm (ocaml-gsl-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 789c828fd3..b4668463c0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5025,6 +5025,26 @@ Atom.")
the OCaml language.")
(license license:gpl3+)))
+(define-public ocaml-gsl-1
+ (package
+ (inherit ocaml-gsl)
+ (version "1.19.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mmottl/gsl-ocaml"
+ "/releases/download/v"
+ version "/gsl-ocaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("gsl" ,gsl)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)))
+ (arguments '())
+ (propagated-inputs '())))
+
(define-public cubicle
(package
(name "cubicle")