summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-11 21:52:00 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-11 22:28:37 +0100
commitbd2337228d7576ce84fa06c581b47817bd215478 (patch)
treefd906853dd52b0d715bbd3242e2d6c87003eb15c /gnu
parent413f71f3fe2fc608228e1a1e3f9de701c3b3a4cd (diff)
downloadpatches-bd2337228d7576ce84fa06c581b47817bd215478.tar
patches-bd2337228d7576ce84fa06c581b47817bd215478.tar.gz
gnu: Add Guile-Git.
* gnu/packages/guile.scm (guile-git): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0ceababba3..52b92453f7 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages maths)
#:use-module (gnu packages image)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
#:use-module (guix packages)
@@ -1579,4 +1580,42 @@ library for GNU Guile based on the actor model.
Note that 8sync is only available for Guile 2.2 (guile-next in Guix).")
(license license:lgpl3+)))
+(define-public guile-git
+ (let ((revision "0")
+ (commit "969514aa7224217bc3c1a4c5312a9469ac5f13d5"))
+ (package
+ (name "guile-git")
+ (version (string-append "0.0-" revision "." (string-take commit 7)))
+ (home-page "https://gitlab.com/amirouche/guile-git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "079l8y6pjkmahb4k6dfqh3hk34pg540rrl29aixyvv86w9bdfjil"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))
+
+ ;; Test suite is not parallel-safe: the tests open same-named repos.
+ #:parallel-tests? #f))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.0)
+ ("libgit2" ,libgit2)))
+ (propagated-inputs
+ `(("guile-bytestructures" ,guile-bytestructures)))
+ (synopsis "Guile bindings for libgit2")
+ (description
+ "This package provides Guile bindings to libgit2, a library to
+manipulate repositories of the Git version control system.")
+ (license license:gpl3+))))
+
;;; guile.scm ends here