summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-08-02 02:00:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-08-02 02:01:17 +0200
commita17fe3f01ac160a576135b03d23bc098ebf6fb31 (patch)
tree094860abf9379be87f51de1f56924c151dc6564d /gnu
parent61919f09813a0adf97024d10b52fb9017029fe94 (diff)
downloadpatches-a17fe3f01ac160a576135b03d23bc098ebf6fb31.tar
patches-a17fe3f01ac160a576135b03d23bc098ebf6fb31.tar.gz
gnu: Add missing pcre2-fix-jit_match-crash.patch.
* gnu/packages/patches/pcre2-fix-jit_match-crash.patch: Really new file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/pcre2-fix-jit_match-crash.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/pcre2-fix-jit_match-crash.patch b/gnu/packages/patches/pcre2-fix-jit_match-crash.patch
new file mode 100644
index 0000000000..7543319ee9
--- /dev/null
+++ b/gnu/packages/patches/pcre2-fix-jit_match-crash.patch
@@ -0,0 +1,25 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Thu, 01 Aug 2019 21:12:52 +0200
+Subject: [PATCH] gnu: pcre2: Fix jit_match crash.
+
+Fixes <https://bugs.exim.org/show_bug.cgi?id=2421>, reported as a ‘secrity
+problem’.
+
+Copied verbatim from upstream[0].
+
+[0]: https://vcs.pcre.org/pcre2/code/trunk/src/pcre2_jit_compile.c?view=patch&r1=1089&r2=1092&pathrev=1092
+
+--- trunk/src/pcre2_jit_compile.c 2019/05/10 13:15:20 1089
++++ trunk/src/pcre2_jit_compile.c 2019/05/13 16:38:18 1092
+@@ -8571,7 +8571,10 @@
+ PCRE2_SPTR bptr;
+ uint32_t c;
+
+-GETCHARINC(c, cc);
++/* Patch by PH */
++/* GETCHARINC(c, cc); */
++
++c = *cc++;
+ #if PCRE2_CODE_UNIT_WIDTH == 32
+ if (c >= 0x110000)
+ return NULL;