summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-06-12 14:46:39 +0200
committerJohn Darrington <jmd@gnu.org>2014-06-12 16:01:56 +0200
commit8c6cfd553e9e2a0c4ab65ae5768dfea23146d2f9 (patch)
tree9bfe5b11050fde250f1f0df946206e5faf9b7dcf /gnu
parentb6b097ac8114510c380a9293bf50f797c57ff3ed (diff)
downloadpatches-8c6cfd553e9e2a0c4ab65ae5768dfea23146d2f9.tar
patches-8c6cfd553e9e2a0c4ab65ae5768dfea23146d2f9.tar.gz
gnu: Add dropbear.
* gnu/packages/ssh.scm (dropbear): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c8ed3be4a7..f9805d3316 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -321,3 +321,23 @@ connectivity, and provides intelligent local echo and line editing of user
keystrokes. Mosh is a replacement for SSH. It's more robust and responsive,
especially over Wi-Fi, cellular, and long-distance links.")
(license license:gpl3+)))
+
+(define-public dropbear
+ (package
+ (name "dropbear")
+ (version "2014.63")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://matt.ucc.asn.au/" name "/releases/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "1bjpbg2vi5f332q4bqxkidkjfxsqmnqvp4g1wyh8d99b8gg94nar"))))
+ (build-system gnu-build-system)
+ (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
+ (inputs `(("zlib" ,zlib)))
+ (synopsis "Small SSH server and client")
+ (description "Dropbear is a relatively small SSH server and
+client. It runs on a variety of POSIX-based platforms. Dropbear is
+particularly useful for embedded systems, such as wireless routers.")
+ (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
+ (license (license:x11-style "" "See file LICENSE."))))