summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-02-01 20:20:54 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-13 22:50:17 +0100
commit70c7d02590a93d3950747a9538e3882cb34bcd49 (patch)
tree4da37a6eb23ce45d57b3397782ff53152ae9cad4 /gnu
parentec23bae682ab144179fad8d5ed6c2545d85384ad (diff)
downloadpatches-70c7d02590a93d3950747a9538e3882cb34bcd49.tar
patches-70c7d02590a93d3950747a9538e3882cb34bcd49.tar.gz
gnu: Add ocaml-earley.
* gnu/packages/ocaml.scm (ocaml-earley): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 07fcf92aea..0098806bcb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4683,6 +4683,31 @@ in-line tests in ocaml code. It is part of Jane Street's PPX rewriters
collection.")
(license license:expat)))
+(define-public ocaml-earley
+ (package
+ (name "ocaml-earley")
+ (version "2.0.0")
+ (home-page "https://github.com/rlepigre/ocaml-earley")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18k7bi7krc4bvqnhijz1q0pfr0nfahghfjifci8rh1q4i5zd0xz5"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "."))
+ (synopsis "Parsing library based on Earley Algorithm")
+ (description "Earley is a parser combinator library base on Earley's
+algorithm. It is intended to be used in conjunction with an OCaml syntax
+extension which allows the definition of parsers inside the language. There
+is also support for writing OCaml syntax extensions in a camlp4 style.")
+ (license license:cecill-b)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")