summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2016-05-30 21:16:38 +0200
committerTomáš Čech <sleep_walker@gnu.org>2016-05-31 22:08:10 +0200
commit6ba8ca17fb43a1f70e4ca6a7797ef8e63d1a21e5 (patch)
tree967f90217fa006cad19d88b82b644e0abec3574d /gnu
parentc095330a8ce25a7bcd7cbf020af5ed8402b19764 (diff)
downloadpatches-6ba8ca17fb43a1f70e4ca6a7797ef8e63d1a21e5.tar
patches-6ba8ca17fb43a1f70e4ca6a7797ef8e63d1a21e5.tar.gz
gnu: Add py3status.
* gnu/packages/python.scm (python-py3status): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dc54bff4b5..701ee45e17 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8788,3 +8788,24 @@ the renaming, moving and extracting of attributes, functions, modules, fields
and parameters in Python 2 source code. These refactorings can also be applied
to occurences in strings and comments.")
(license gpl2)))
+
+(define-public python-py3status
+ (package
+ (name "python-py3status")
+ (version "2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "py3status" version))
+ (sha256
+ (base32
+ "09y7h8rjay5kzwk5akq7f5f9wqnvjkxhivck04hdc8ny1nw3vqzp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/ultrabug/py3status")
+ (synopsis "Extensible i3status wrapper written in Python")
+ (description "py3status is an i3status wrapper which extends i3status
+functionality in a modular way, allowing you to extend your panel with your
+own code, responding to click events and updating clock every second.")
+ (license bsd-3)))