summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-02-14 00:10:01 +0100
committerAndreas Enge <andreas@enge.fr>2019-02-14 00:30:27 +0100
commit69c15ad8a46c8e5f319a73ee5891bcd1bf0600c5 (patch)
tree5fa6d8eaa4f37eb3a7006602974435e9ecea5ca2 /gnu
parent58c6a93d9d60660d8425d8c52d4b73a42d4a5b55 (diff)
downloadpatches-69c15ad8a46c8e5f319a73ee5891bcd1bf0600c5.tar
patches-69c15ad8a46c8e5f319a73ee5891bcd1bf0600c5.tar.gz
gnu: qtbase: Restore compilation on linux kernels < 4.11.
Fixes <https://bugs.gnu.org/34431>. * gnu/packages/patches/qtbase-old-kernel.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. * gnu/packages/qt.scm (qtbase): Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qtbase-old-kernel.patch25
-rw-r--r--gnu/packages/qt.scm3
3 files changed, 28 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3d9d334ac6..a73f10b0f8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1180,6 +1180,7 @@ dist_patch_DATA = \
%D%/packages/patches/qemu-CVE-2018-16872.patch \
%D%/packages/patches/qemu-CVE-2019-6778.patch \
%D%/packages/patches/qt4-ldflags.patch \
+ %D%/packages/patches/qtbase-old-kernel.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
diff --git a/gnu/packages/patches/qtbase-old-kernel.patch b/gnu/packages/patches/qtbase-old-kernel.patch
new file mode 100644
index 0000000000..aa26fb6c4f
--- /dev/null
+++ b/gnu/packages/patches/qtbase-old-kernel.patch
@@ -0,0 +1,25 @@
+https://672856.bugs.gentoo.org/attachment.cgi?id=557978
+https://bugs.gentoo.org/672856
+
+The patch fixes building qtbase with linux kernels < 4.11.
+See bug #34431.
+
+diff -Naurp a/src/corelib/global/minimum-linux_p.h b/src/corelib/global/minimum-linux_p.h
+--- a/src/corelib/global/minimum-linux_p.h 2018-11-25 15:51:11.000000000 +0300
++++ b/src/corelib/global/minimum-linux_p.h 2018-12-17 13:25:38.176823753 +0300
+@@ -75,14 +75,9 @@ QT_BEGIN_NAMESPACE
+ * - accept4 2.6.28
+ * - renameat2 3.16 QT_CONFIG(renameat2)
+ * - getrandom 3.17 QT_CONFIG(getentropy)
+- * - statx 4.11 QT_CONFIG(statx)
+ */
+
+-#if QT_CONFIG(statx)
+-# define MINLINUX_MAJOR 4
+-# define MINLINUX_MINOR 11
+-# define MINLINUX_PATCH 0
+-#elif QT_CONFIG(getentropy)
++#if QT_CONFIG(getentropy)
+ # define MINLINUX_MAJOR 3
+ # define MINLINUX_MINOR 17
+ # define MINLINUX_PATCH 0
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6775a991b9..664309cb52 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -512,7 +512,8 @@ system, and the core design of Django is reused in Grantlee.")
(base32
"071yc9iz14qs4s8yvrwllyfdzp5yjxsdpvbjxdrf0g5q69vqigy6"))
;; Use TZDIR to avoid depending on package "tzdata".
- (patches (search-patches "qtbase-use-TZDIR.patch"))
+ (patches (search-patches "qtbase-use-TZDIR.patch"
+ "qtbase-old-kernel.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3