summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-29 16:37:28 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-30 12:36:27 -0500
commit22c246211237934b38e9d4524b1daef0e144ddd1 (patch)
tree8c5859283b6e8257b7d01e1e3a3d74eb84c604d8 /gnu
parentd42e61224e731c7c8f5d67d4d5f7468f67588632 (diff)
downloadpatches-22c246211237934b38e9d4524b1daef0e144ddd1.tar
patches-22c246211237934b38e9d4524b1daef0e144ddd1.tar.gz
gnu: Add btar.
* gnu/packages/backup.scm (btar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 747c3f026c..e5ff2373e1 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -152,3 +152,35 @@ Rdup itself does not backup anything, it only print a list of absolute
filenames to standard output. Auxiliary scripts are needed that act on this
list and implement the backup strategy.")
(license gpl3+)))
+
+(define-public btar
+ (package
+ (name "btar")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://vicerveza.homeunix.net/~viric/soft/btar/"
+ "btar-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0miklk4bqblpyzh1bni4x6lqn88fa8fjn15x1k1n8bxkx60nlymd"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("librsync" ,librsync)))
+ (arguments
+ `(#:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:tests? #f ;test input not distributed
+ #:phases
+ (alist-delete
+ 'configure ;no configure phase
+ %standard-phases)))
+ (home-page "http://viric.name/cgi-bin/btar/doc/trunk/doc/home.wiki")
+ (synopsis "Tar-compatible archiver")
+ (description
+ "Btar is a tar-compatible archiver which allows arbitrary compression and
+ciphering, redundancy, differential backup, indexed extraction, multicore
+compression, input and output serialisation, and tolerance to partial archive
+errors.")
+ (license gpl3+)))