summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-20 19:57:28 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-20 20:01:10 +0100
commitea8be005d409658dea4f4356e9279784ce0a5a39 (patch)
tree5e2e22332f37cbf171a75d524b60a87c7f8afd12 /gnu
parent86974d8a9247cbeb938b5202f23ccca8d9ed627d (diff)
downloadpatches-ea8be005d409658dea4f4356e9279784ce0a5a39.tar
patches-ea8be005d409658dea4f4356e9279784ce0a5a39.tar.gz
gnu: Use i686-linux bootstrap binaries on x86_64-linux.
This saves 4.4 MB on the installed Guix. * gnu/packages/bootstrap/x86_64-linux: Remove directory. * gnu/local.mk (bootstrap_x86_64_linuxdir) (dist_bootstrap_x86_64_linux_DATA): Remove. * gnu/packages.scm (search-bootstrap-binary): When SYSTEM is "x86_64-linux", use "i686-linux" instead.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk7
-rw-r--r--gnu/packages.scm18
-rwxr-xr-xgnu/packages/bootstrap/x86_64-linux/bashbin1425560 -> 0 bytes
-rwxr-xr-xgnu/packages/bootstrap/x86_64-linux/mkdirbin792448 -> 0 bytes
-rwxr-xr-xgnu/packages/bootstrap/x86_64-linux/tarbin1369912 -> 0 bytes
-rwxr-xr-xgnu/packages/bootstrap/x86_64-linux/xzbin927264 -> 0 bytes
6 files changed, 11 insertions, 14 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9cf690e0f1..7c970dc47c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1287,18 +1287,11 @@ MISC_DISTRO_FILES = \
%D%/packages/ld-wrapper.in
bootstrapdir = $(guilemoduledir)/%D%/packages/bootstrap
-bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
bootstrap_i686_linuxdir = $(bootstrapdir)/i686-linux
bootstrap_armhf_linuxdir = $(bootstrapdir)/armhf-linux
bootstrap_aarch64_linuxdir = $(bootstrapdir)/aarch64-linux
bootstrap_mips64el_linuxdir = $(bootstrapdir)/mips64el-linux
-dist_bootstrap_x86_64_linux_DATA = \
- %D%/packages/bootstrap/x86_64-linux/bash \
- %D%/packages/bootstrap/x86_64-linux/mkdir \
- %D%/packages/bootstrap/x86_64-linux/tar \
- %D%/packages/bootstrap/x86_64-linux/xz
-
dist_bootstrap_i686_linux_DATA = \
%D%/packages/bootstrap/i686-linux/bash \
%D%/packages/bootstrap/i686-linux/mkdir \
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 532297239d..333b18f9f0 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -102,14 +102,18 @@ FILE-NAME found in %PATCH-PATH."
(define (search-bootstrap-binary file-name system)
"Search the bootstrap binary FILE-NAME for SYSTEM. Raise an error if not
found."
- (or (search-path (%bootstrap-binaries-path)
- (string-append system "/" file-name))
- (raise (condition
- (&message
- (message
- (format #f (G_ "could not find bootstrap binary '~a' \
+ ;; On x86_64 always use the i686 binaries.
+ (let ((system (match system
+ ("x86_64-linux" "i686-linux")
+ (_ system))))
+ (or (search-path (%bootstrap-binaries-path)
+ (string-append system "/" file-name))
+ (raise (condition
+ (&message
+ (message
+ (format #f (G_ "could not find bootstrap binary '~a' \
for system '~a'")
- file-name system)))))))
+ file-name system))))))))
(define %distro-root-directory
;; Absolute file name of the module hierarchy. Since (gnu packages …) might
diff --git a/gnu/packages/bootstrap/x86_64-linux/bash b/gnu/packages/bootstrap/x86_64-linux/bash
deleted file mode 100755
index b9c410b7cf..0000000000
--- a/gnu/packages/bootstrap/x86_64-linux/bash
+++ /dev/null
Binary files differ
diff --git a/gnu/packages/bootstrap/x86_64-linux/mkdir b/gnu/packages/bootstrap/x86_64-linux/mkdir
deleted file mode 100755
index f8250ae693..0000000000
--- a/gnu/packages/bootstrap/x86_64-linux/mkdir
+++ /dev/null
Binary files differ
diff --git a/gnu/packages/bootstrap/x86_64-linux/tar b/gnu/packages/bootstrap/x86_64-linux/tar
deleted file mode 100755
index 90e492f89d..0000000000
--- a/gnu/packages/bootstrap/x86_64-linux/tar
+++ /dev/null
Binary files differ
diff --git a/gnu/packages/bootstrap/x86_64-linux/xz b/gnu/packages/bootstrap/x86_64-linux/xz
deleted file mode 100755
index 6bfe3c6d96..0000000000
--- a/gnu/packages/bootstrap/x86_64-linux/xz
+++ /dev/null
Binary files differ