summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 10:12:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 10:12:38 +0100
commit7b93d866708d1fae54aee86473ffde5bd64be055 (patch)
tree3ffe25590823b9ced9824d778b85dc2292bb85ea /gnu
parent972cf9be524535fee3999021a68537039e204ee6 (diff)
downloadpatches-7b93d866708d1fae54aee86473ffde5bd64be055.tar
patches-7b93d866708d1fae54aee86473ffde5bd64be055.tar.gz
gnu: snakemake: Update to 3.9.0.
* gnu/packages/python.scm (snakemake): Update to 3.9.0. [source]: Use 'pypi-uri'. [arguments]: Disable tests. [home-page]: Update.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 04ee836c6c..cbe770db39 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5306,17 +5306,18 @@ of the structure, dynamics, and functions of complex networks.")
(define-public snakemake
(package
(name "snakemake")
- (version "3.2.1")
+ (version "3.9.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/s/snakemake/snakemake-"
- version ".tar.gz"))
+ (uri (pypi-uri "snakemake" version))
(sha256
- (base32 "0fi4b63sj60hvi7rfydvmz2icl4wj74djw5sn2gl8hxd02qw4b91"))))
+ (base32 "1d48ql0010v9ls6mac7fz6j391gm4h74a64hqgw89s0vfqgdyzdl"))))
(build-system python-build-system)
- (home-page "https://bitbucket.org/johanneskoester/snakemake")
+ (arguments
+ ;; TODO: Package missing test dependencies.
+ '(#:tests? #f))
+ (home-page "https://bitbucket.org/snakemake/snakemake/wiki/Home")
(synopsis "Python-based execution environment for make-like workflows")
(description
"Snakemake aims to reduce the complexity of creating workflows by