summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:33:20 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:09:14 +0200
commit37a0f47073e1788e8991567c4fce5d2acaa8ce67 (patch)
tree79a6bd3d1e3923aa7a63f5605526b13fe93ae1e7 /gnu
parent49e1dde53fd0a2e3c1d636364c067de8dbb611d7 (diff)
downloadpatches-37a0f47073e1788e8991567c4fce5d2acaa8ce67.tar
patches-37a0f47073e1788e8991567c4fce5d2acaa8ce67.tar.gz
gnu: Add ruby-jekyll-paginate-v2.
* gnu/packages/ruby.scm (ruby-jekyll-paginate-v2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 70c071f921..616b86934d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5908,3 +5908,22 @@ Pathname.")
(synopsis "Static site generator")
(description "Jekyll is a simple, blog aware, static site generator.")
(license license:expat)))
+
+(define-public ruby-jekyll-paginate-v2
+ (package
+ (name "ruby-jekyll-paginate-v2")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-paginate-v2" version))
+ (sha256
+ (base32
+ "154bfpyml6abxww9868hhyfvxasl8qhsc5zy2q30c7dxaj0igdib"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("jekyll" ,jekyll)))
+ (home-page "https://github.com/sverrirs/jekyll-paginate-v2")
+ (synopsis "Pagination Generator for Jekyll 3")
+ (description "The Pagination Generator forms the core of the pagination
+logic in Jekyll. It calculates and generates the pagination pages.")
+ (license license:expat)))