summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:08:08 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:55 +0200
commit2e072e37aa0c5cf0fc612c9e4d5540cec6189b13 (patch)
treef2cf963aea53d2dbdb7d34f6e2547b65dcf772e7 /gnu
parent2c5028bd97d50723b1a0ad1b2b5781487779b78b (diff)
downloadpatches-2e072e37aa0c5cf0fc612c9e4d5540cec6189b13.tar
patches-2e072e37aa0c5cf0fc612c9e4d5540cec6189b13.tar.gz
gnu: Add ruby-hashie.
* gnu/packages/ruby.scm (ruby-hashie): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9aabd4ff8f..bfb98a0bff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5719,3 +5719,23 @@ is compatible with stylesheets designed for pygments.")
(sha256
(base32
"02kpahk5nkc33yxnn75649kzxaz073wvazr2zyg491nndykgnvcs"))))))
+
+(define-public ruby-hashie
+ (package
+ (name "ruby-hashie")
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hashie" version))
+ (sha256
+ (base32
+ "13bdzfp25c8k51ayzxqkbzag3wj5gc1jd8h7d985nsq6pn57g5xh"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (arguments `(#:tests? #f)); FIXME: Could not locate Gemfile or .bundle/ directory
+ (home-page "https://github.com/intridea/hashie")
+ (synopsis "Extensions to Ruby Hashes")
+ (description "Hashie is a collection of classes and mixins that make Ruby
+hashes more powerful.")
+ (license license:expat)))