summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:11:15 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit2108eac211c44ecaf12bcd8662d757737585677e (patch)
treed2894fc8a82fcf0a7df8a35232497bd65b62d48d /gnu
parentd10fed28b820dcd0a287d3aead15a87602985100 (diff)
downloadpatches-2108eac211c44ecaf12bcd8662d757737585677e.tar
patches-2108eac211c44ecaf12bcd8662d757737585677e.tar.gz
gnu: Add ghc-quickcheck-unicode.
* gnu/packages/haskell.scm (ghc-quickcheck-unicode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 74a8c2f67d..0a8cb01f6c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1175,6 +1175,29 @@ installed.")
writing to stdout and other handles.")
(license bsd-3)))
+(define-public ghc-quickcheck-unicode
+ (package
+ (name "ghc-quickcheck-unicode")
+ (version "1.0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/quickcheck-unicode/quickcheck-unicode-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1a8nl6x7l9b22yx61wm0bh2n1xzb1hd5i5zgg1w4fpaivjnrrhi4"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page
+ "https://github.com/bos/quickcheck-unicode")
+ (synopsis "Generator functions Unicode-related tests")
+ (description "This package provides generator and shrink functions for
+testing Unicode-related software.")
+ (license bsd-3)))
+
(define-public ghc-quickcheck-io
(package
(name "ghc-quickcheck-io")