summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:33:08 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:10 +0200
commit00d71efca6be6bff7e2bb0f5a61ae8a7929af39a (patch)
treec73d667cbfa00c0d5360fc51827bde22c4da443e /gnu
parent83d9f672212907bb0c683f0be428c1d847bf6001 (diff)
downloadpatches-00d71efca6be6bff7e2bb0f5a61ae8a7929af39a.tar
patches-00d71efca6be6bff7e2bb0f5a61ae8a7929af39a.tar.gz
gnu: Add ruby-morecane.
* gnu/packages/ruby.scm (ruby-morecane): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b7a55fa31f..93ed29443e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5443,3 +5443,25 @@ suited for map-reduce or e.g. parallel downloads/uploads.")
(synopsis "Code quality threshold checking")
(description "Cane fails your build if code quality thresholds are not met.")
(license license:asl2.0)))
+
+(define-public ruby-morecane
+ (package
+ (name "ruby-morecane")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "morecane" version))
+ (sha256
+ (base32
+ "0w70vb8z5bdhvr21h660aa43m5948pv0bd27z7ngai2iwdvqd771"))))
+ (build-system ruby-build-system)
+ (home-page "https://github.com/yob/morecane")
+ (arguments `(#:tests? #f)); No rakefile
+ (propagated-inputs
+ `(("ruby-parallel" ,ruby-parallel)))
+ (synopsis "Extra checks for cane")
+ (description "The cane gem provides a great framework for running quality
+checks over your ruby project as part of continuous integration build. It
+comes with a few checks out of the box, but also provides an API for loading
+custom checks. This gem provides a set of additional checks.")
+ (license license:expat)))