summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-02 20:38:03 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-02 20:38:03 +0100
commitba6f8e423e582ad1fc1b164317d158e3e1c0f6af (patch)
tree5ecabace73cf9b4a117e679d7a02d04259ae9ea3 /gnu
parentf6a9d0484c6cdd1554f6ce0e7372ec8b7f2a52ca (diff)
downloadpatches-ba6f8e423e582ad1fc1b164317d158e3e1c0f6af.tar
patches-ba6f8e423e582ad1fc1b164317d158e3e1c0f6af.tar.gz
gnu: Add xterm.
* gnu/packages/xorg.scm (xterm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fbb6367d05..abcbfba88a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -38,7 +38,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages ncurses))
@@ -4709,3 +4710,44 @@ icccm: Both client and window-manager helpers for ICCCM.")
(synopsis "xorg implementation of the X Window System")
(description "X.org provides an implementation of the X Window System")
(license license:x11)))
+
+(define-public xterm
+ (package
+ (name "xterm")
+ (version "301")
+ (source (origin
+ (method url-fetch)
+ (uri ; XXX: constant URL!
+ "http://invisible-island.net/datafiles/release/xterm.tar.gz")
+ (sha256
+ (base32
+ "040rarvv18zg0lk7qy0m3n7gv10mh40jic708wvng01z4rlbpfhz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-wide-chars" "--enable-256-color"
+ "--enable-load-vt-fonts" "--enable-i18n"
+ "--enable-doublechars" "--enable-luit"
+ "--enable-mini-luit")
+ #:tests? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("luit" ,luit)
+ ("libXft" ,libxft)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("ncurses" ,ncurses)
+ ("libICE" ,libice)
+ ("libSM" ,libsm)
+ ("libX11" ,libx11)
+ ("libXext" ,libxext)
+ ("libXt" ,libxt)
+ ("xproto" ,xproto)
+ ("libXaw" ,libxaw)))
+ (home-page "http://invisible-island.net/xterm")
+ (synopsis "Terminal emulator for the X Window System")
+ (description
+ "The xterm program is a terminal emulator for the X Window System. It
+provides DEC VT102/VT220 (VTxxx) and Tektronix 4014 compatible terminals for
+programs that cannot use the window system directly.")
+ (license license:x11)))