summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-11 11:39:57 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-12 00:14:32 +0100
commitb4fcb735d55ad5111fdbef9e4af2ca9ff7e86052 (patch)
treef239bd641fab7ba2f54dec68cf98e56de2fbc2f0 /gnu
parentea4d96c6a5ceae45a640928a3783bea3500f78d6 (diff)
downloadpatches-b4fcb735d55ad5111fdbef9e4af2ca9ff7e86052.tar
patches-b4fcb735d55ad5111fdbef9e4af2ca9ff7e86052.tar.gz
gnu: Add Linux module-init-tools.
* gnu/packages/linux.scm (module-init-tools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 58cddc0d1c..90fa004b65 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -83,6 +83,45 @@
(license gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
+(define-public module-init-tools
+ (package
+ (name "module-init-tools")
+ (version "3.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel.org/linux/utils/kernel/module-init-tools/module-init-tools-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0jxnz9ahfic79rp93l5wxcbgh4pkv85mwnjlbv1gz3jawv5cvwp1"))))
+ (build-system gnu-build-system)
+ (inputs
+ ;; The upstream tarball lacks man pages, and building them would require
+ ;; DocBook & co. Thus, use Gentoo's pre-built man pages.
+ `(("man-pages"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "http://distfiles.gentoo.org/distfiles/module-init-tools-" version
+ "-man.tar.bz2"))
+ (sha256
+ (base32
+ "1j1nzi87kgsh4scl645fhwhjvljxj83cmdasa4n4p5krhasgw358"))))))
+ (arguments
+ '(#:phases (alist-cons-before
+ 'unpack 'unpack-man-pages
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((man-pages (assoc-ref inputs "man-pages")))
+ (zero? (system* "tar" "xvf" man-pages))))
+ %standard-phases)))
+ (home-page "http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/")
+ (synopsis "Tools for loading and managing Linux kernel modules")
+ (description
+ "Tools for loading and managing Linux kernel modules, such as `modprobe',
+`insmod', `lsmod', and more.")
+ (license gpl2+)))
+
(define-public linux-pam
(package
(name "linux-pam")