summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-08-05 20:59:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-08-05 21:03:31 +0200
commit7b88b7112045004479a788dda050dce940202adc (patch)
treecfd803a1fc5b8e35a72a7738338ff6a5246ecfef /gnu
parentd866acca9a00e528b3b823873da8a0749c830b85 (diff)
downloadpatches-7b88b7112045004479a788dda050dce940202adc.tar
patches-7b88b7112045004479a788dda050dce940202adc.tar.gz
gnu: libvirt: Update to 5.6.0.
* gnu/packages/virtualization.scm (libvirt): Update to 5.6.0. [source]: Remove patch. * gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch34
-rw-r--r--gnu/packages/virtualization.scm6
3 files changed, 2 insertions, 39 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9e1b0f87c3..6f33a86ecd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1045,7 +1045,6 @@ dist_patch_DATA = \
%D%/packages/patches/libutils-add-includes.patch \
%D%/packages/patches/libutils-remove-damaging-includes.patch \
%D%/packages/patches/libvdpau-va-gl-unbundle.patch \
- %D%/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libvpx-use-after-free-in-postproc.patch \
%D%/packages/patches/libxslt-generated-ids.patch \
diff --git a/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch b/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch
deleted file mode 100644
index 5bfefa70bb..0000000000
--- a/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Thu, 25 Jul 2019 21:48:25 +0200
-Subject: [PATCH]: libvirt: remove ATTRIBUTE_UNUSED
-
-This should fix the error reported here[0]. Patch taken verbatim from
-upstream[1].
-
-[0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36634#28
-[1]: https://github.com/libvirt/libvirt/commit/759bf903a6c24a8efa25c7cf4b099d952eda9bd3
-
-From 759bf903a6c24a8efa25c7cf4b099d952eda9bd3 Mon Sep 17 00:00:00 2001
-From: Pavel Hrdina <phrdina@redhat.com>
-Date: Mon, 22 Jul 2019 14:46:34 +0200
-Subject: [PATCH] vircgroupv2: remove ATTRIBUTE_UNUSED for used attribute
-
-Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
-Acked-by: Peter Krempa <pkrempa@redhat.com>
----
- src/util/vircgroupv2.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/util/vircgroupv2.c b/src/util/vircgroupv2.c
-index af3192c99c..e36c36685b 100644
---- a/src/util/vircgroupv2.c
-+++ b/src/util/vircgroupv2.c
-@@ -399,7 +399,7 @@ virCgroupV2EnableController(virCgroupPtr group,
-
-
- static int
--virCgroupV2MakeGroup(virCgroupPtr parent ATTRIBUTE_UNUSED,
-+virCgroupV2MakeGroup(virCgroupPtr parent,
- virCgroupPtr group,
- bool create,
- unsigned int flags)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index a58e3bf89a..26477714e4 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -390,16 +390,14 @@ manage system or application containers.")
(define-public libvirt
(package
(name "libvirt")
- (version "5.5.0")
+ (version "5.6.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://libvirt.org/sources/libvirt-"
version ".tar.xz"))
(sha256
- (base32 "1s1mzw4cmkcfivs1kphpgy4lpddx0w1qnjysr4ggk5558w4yy1i3"))
- (patches
- (search-patches "libvirt-remove-ATTRIBUTE_UNUSED.patch"))))
+ (base32 "1d5rmcx5fgb024hw8chbiv886n3jal5wp2yajjk5l4qh9s9gkx35"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags