summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-11-02 18:18:16 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-11-02 18:58:26 +0300
commit141bae73d62c166fde9b389322667a9e9961b4bc (patch)
treebd19ad4d3847b8bd15b1b80cfcdd3106b653f0d0 /gnu
parentedf2ac99bdc00a20bd9af16c6cc6cf22233b4c05 (diff)
downloadpatches-141bae73d62c166fde9b389322667a9e9961b4bc.tar
patches-141bae73d62c166fde9b389322667a9e9961b4bc.tar.gz
gnu: Add emacs-tramp-auto-auth.
* gnu/packages/emacs-xyz.scm (emacs-tramp-auto-auth): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 037220ed9e..b819a7bb7e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18699,6 +18699,29 @@ well as an option for visually flashing evaluated s-expressions.")
SSH servers.")
(license license:gpl3+)))
+(define-public emacs-tramp-auto-auth
+ (let ((commit "f15a12dfab651aff60f4a9d70f868030a12344ac"))
+ (package
+ (name "emacs-tramp-auto-auth")
+ (version (git-version "20191027" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oitofelix/tramp-auto-auth.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09nkjgwppjfgv04q0gv468qihgx4y3p39lpwbd6vbh3wgbccas9k"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/oitofelix/tramp-auto-auth")
+ (synopsis "TRAMP automatic authentication library")
+ (description "This package provides @code{tramp-auto-auth-mode} Emacs
+global minor mode whose purpose is to automatically feed TRAMP sub-processes
+with passwords for paths matching regexps.")
+ (license license:gpl3+))))
+
(define-public emacs-eacl
(package
(name "emacs-eacl")