summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-29 09:39:17 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-07 11:40:06 +0200
commit12da2a5e58c6f518892376df5e1af4a511f12e6b (patch)
treeba0c122b3f8a9287c61962bf61c77725d0a969ed /gnu
parentcadc10a513af2624c9233fb2cffb4c4ff5471197 (diff)
downloadpatches-12da2a5e58c6f518892376df5e1af4a511f12e6b.tar
patches-12da2a5e58c6f518892376df5e1af4a511f12e6b.tar.gz
gnu: Add r-abctools.
* gnu/packages/cran.scm (r-abctools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 93c111bccc..aa58efce7c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5460,3 +5460,28 @@ parameter inference via random forests. This machine learning tool named random
forests (RF) can conduct selection among the highly complex models covered by
ABC algorithms.")
(license license:gpl2+)))
+
+(define-public r-abctools
+ (package
+ (name "r-abctools")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abctools" version))
+ (sha256
+ (base32 "07s9dg10i8lsxl73b4n2hynca2fjgb0ykb0dz8c3zv6cgw3cyx97"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abc" ,r-abc)
+ ("r-abind" ,r-abind)
+ ("r-hmisc" ,r-hmisc)
+ ("r-plyr" ,r-plyr)))
+ (home-page "https://github.com/dennisprangle/abctools/")
+ (synopsis "Tools for ABC analyses")
+ (description
+ "This @code{r-abctools} package provides tools for approximate Bayesian computation
+including summary statistic selection and assessing coverage. This includes
+recent dimension reduction algorithms to tune the choice of summary statistics,
+and coverage methods to tune the choice of threshold.")
+ (license license:gpl2+)))