summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-06 16:43:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commitb33f913d9cc5154c4f30103256c7ba2c43be5e08 (patch)
tree66d3fb46aa8fd189fbe0a248aea6bc48b090b70f /gnu
parent8d81016344e67d107b353abe71886320619b4c4d (diff)
downloadpatches-b33f913d9cc5154c4f30103256c7ba2c43be5e08.tar
patches-b33f913d9cc5154c4f30103256c7ba2c43be5e08.tar.gz
gnu: Add emacs-smart-mode-line.
* gnu/packages/emacs.scm (emacs-smart-mode-line): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c074ff0691..a2b8ba2172 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1506,6 +1506,30 @@ in Lisp modes.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-smart-mode-line
+ (package
+ (name "emacs-smart-mode-line")
+ (version "2.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Malabarba/smart-mode-line/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i9wajabrrsjzwd842q0m2611kf0q31p9hg1pdj81177gynkw8l8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-rich-minority" ,emacs-rich-minority)))
+ (home-page "http://github.com/Malabarba/smart-mode-line")
+ (synopsis "Color-coded smart mode-line.")
+ (description
+ "Smart Mode Line is a mode-line theme for Emacs. It aims to be easy to
+read from small to large monitors by using colors, a prefix feature, and smart
+truncation.")
+ (license license:gpl2+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")