summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-04 16:13:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-05 02:40:07 +0100
commitf38eabe952608478230895e380ef441d65ea625e (patch)
tree877afd0bb36e7424574212aba4f9bcde77c8adf2 /gnu
parent6925c85573265a39cc1d0e42e447580fd562db39 (diff)
downloadpatches-f38eabe952608478230895e380ef441d65ea625e.tar
patches-f38eabe952608478230895e380ef441d65ea625e.tar.gz
gnu: ncompress: Update to 4.2.4.6.
* gnu/packages/compression.scm (ncompress): Update to 4.2.4.6. * gnu/packages/patches/ncompress-fix-softlinks.patch: Adjust.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm6
-rw-r--r--gnu/packages/patches/ncompress-fix-softlinks.patch7
2 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index cf23e88547..cb73dcec75 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -2091,7 +2091,7 @@ possibly untrusted extraction shell script.")
(define-public ncompress
(package
(name "ncompress")
- (version "4.2.4.5")
+ (version "4.2.4.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2101,7 +2101,7 @@ possibly untrusted extraction shell script.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0s3ik7k5a5vzcfiayhsxrc87drg3l425aqapspmw5py91b9jhc8r"))))
+ "1a4yir1ilafz0nzxdwigj204j4yy2zljbc501nsaqqm3dxdap8zn"))))
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "BINDIR=" %output "/bin")
diff --git a/gnu/packages/patches/ncompress-fix-softlinks.patch b/gnu/packages/patches/ncompress-fix-softlinks.patch
index 98752e8e64..d667e3ef74 100644
--- a/gnu/packages/patches/ncompress-fix-softlinks.patch
+++ b/gnu/packages/patches/ncompress-fix-softlinks.patch
@@ -1,4 +1,5 @@
-Patch taken from Debian sid.
+Patch taken from Debian sid. Adapted to 4.2.4.6 for Guix by Tobias
+Geerinckx-Rice <me@tobias.gr>.
Description: Support uncompressing and compressing soft links.
Historically, ncompress for Debian has been built using a command line
@@ -17,8 +18,8 @@ Index: ncompress/GNUmakefile
Makefile: Makefile.def GNUmakefile
sed \
-- -e 's:options= :options= $$(CFLAGS) -DNOFUNCDEF -DUTIME_H -DLSTAT $$(LDFLAGS) :' \
-+ -e 's:options= :options= $$(CFLAGS) -DNOFUNCDEF -DUTIME_H $$(LDFLAGS) :' \
+- -e 's:options= :options= -DUTIME_H -DLSTAT :' \
++ -e 's:options= :options= -DUTIME_H :' \
Makefile.def > Makefile
check: