summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <john@darrington.wattle.id.au>2014-11-16 02:54:15 +0100
committerJohn Darrington <jmd@gnu.org>2014-11-18 10:38:13 +0100
commite093274238b0e06c00a4d3e38c550a462d66a3ba (patch)
tree6e01b23f052d9edee8f4a9f5de508c4fdb941904 /gnu
parenta6abac9f2e1f2c0fa0a6d757379b66a8d5fe4286 (diff)
downloadpatches-e093274238b0e06c00a4d3e38c550a462d66a3ba.tar
patches-e093274238b0e06c00a4d3e38c550a462d66a3ba.tar.gz
gnu: Fix cross compilation issue with libgcrypt.
* gnu/packages/gnupg.scm (libgcrypt): Distinguish between the native and non-native libgpg-error input
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index b7cf897a5c..ecbb17895c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -71,17 +71,17 @@ Daemon and possibly more in the future.")
"0k2wi34qhp5hq71w1ab3kw1gfsx7xff79bvynqkxp35kls94826y"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("libgpg-error" ,libgpg-error)))
+ `(("libgpg-error-host" ,libgpg-error)))
(native-inputs
;; Needed here for the 'gpg-error' program.
- `(("libgpg-error" ,libgpg-error)))
+ `(("libgpg-error-native" ,libgpg-error)))
(arguments
;; The '--with-gpg-error-prefix' argument is needed because otherwise
;; 'configure' uses 'gpg-error-config' to determine the '-L' flag, and
;; the 'gpg-error-config' it runs is the native one---i.e., the wrong one.
`(#:configure-flags
(list (string-append "--with-gpg-error-prefix="
- (assoc-ref %build-inputs "libgpg-error")))))
+ (assoc-ref %build-inputs "libgpg-error-host")))))
(outputs '("out" "debug"))
(home-page "http://gnupg.org/")
(synopsis "Cryptographic function library")