summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-21 16:29:13 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-21 16:33:53 +0100
commit9723ce5886e0c291e5337c3328f34d335f77fa88 (patch)
tree745864c843d7df6f48bce8e24d58cdae8f8dece0 /gnu
parent9c960731d64630b1cc1f3fac1fec646dc339a12c (diff)
downloadpatches-9723ce5886e0c291e5337c3328f34d335f77fa88.tar
patches-9723ce5886e0c291e5337c3328f34d335f77fa88.tar.gz
gnu: dbus: Add 1.8.10 as a replacement.
* gnu/packages/glib.scm (dbus)[replacement]: New field. (dbus-1.8.10): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e79be41d1a..be2924c606 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -55,6 +55,7 @@
(package
(name "dbus")
(version "1.8.8")
+ (replacement dbus-1.8.10) ;fix for CVE-2014-7824
(source (origin
(method url-fetch)
(uri
@@ -113,6 +114,20 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
+(define-public dbus-1.8.10
+ (let ((real-version "1.8.10"))
+ (package (inherit dbus)
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://dbus.freedesktop.org/releases/dbus/dbus-"
+ real-version ".tar.gz"))
+ (sha256
+ (base32
+ "13mgvwigm931r8n9363imnn0vn6dvc0m322k3p8fs5c8nvyqggqh"))
+ (patches (list (search-patch "dbus-localstatedir.patch")))))
+ (replacement #f))))
+
(define glib
(package
(name "glib")