summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-22 13:54:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-22 23:02:13 +0200
commit7ac2cab8c92c614e85764a1b2053365f26e0afac (patch)
treed01ed5c434034dffccd0ff13188c5a55f8813b9c /gnu
parent77a0354a362a78340956f53ecab406c37bab414f (diff)
downloadpatches-7ac2cab8c92c614e85764a1b2053365f26e0afac.tar
patches-7ac2cab8c92c614e85764a1b2053365f26e0afac.tar.gz
gnu: Add icedtea-web.
* gnu/packages/java.scm (icedtea-web): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1af80f61ec..652eb6792c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -73,6 +73,7 @@
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages java)
#:use-module (gnu packages javascript)
#:use-module (gnu packages image)
#:use-module (gnu packages libidn)
@@ -306,6 +307,42 @@ such as high performance, preforking, signal support, superdaemon awareness,
and UNIX socket support.")
(license l:perl-license)))
+(define-public icedtea-web
+ (package
+ (name "icedtea-web")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icedtea.wildebeest.org/download/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "004kwrngyxxlrlzby4vzxjr0xcyngcdc9dfgnvi61ffnjr006ryf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-plugin" ;NPAPI plugins are obsolete nowadays.
+ (string-append "BIN_BASH=" (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--with-jdk-home=" (assoc-ref %build-inputs "jdk")))))
+ (outputs '("out" "doc"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("zip" ,zip)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("jdk" ,icedtea "jdk")))
+ (home-page "http://icedtea.classpath.org/wiki/IcedTea-Web")
+ (synopsis "Java Web Start")
+ (description
+ "IcedTea-Web is an implementation of the @dfn{Java Network Launching
+Protocol}, also known as Java Web Start. This package provides tools and
+libraries for working with JNLP applets.")
+ ;; The program is mainly GPL2+, with some individual files under LGPL2.1+
+ ;; or dual licenses.
+ (license l:gpl2+)))
+
(define-public jansson
(package
(name "jansson")