summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-06-26 02:06:25 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-06-26 15:18:25 +0530
commitde2e402be7e9389770e3537ccc5d384c85ea1fa3 (patch)
tree202275deb86af06766ab449c929a15557d5c81d1 /gnu
parent346d5d58740e131a9d942298d32e64a306711263 (diff)
downloadpatches-de2e402be7e9389770e3537ccc5d384c85ea1fa3.tar
patches-de2e402be7e9389770e3537ccc5d384c85ea1fa3.tar.gz
gnu: Add emacs-autothemer.
* gnu/packages/emacs.scm (emacs-autothemer): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ecb6fed6aa..a982788755 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;; Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1139,6 +1140,30 @@ writing input files for TeX, LaTeX, ConTeXt, Texinfo, and docTeX using Emacs
or XEmacs.")
(license license:gpl3+)))
+(define-public emacs-autothemer
+ (package
+ (name "emacs-autothemer")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sebastiansturm/autothemer/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rd28r9wfrbll212am4ih9hrvypx785aff76va2cbfxdwm9kixsa"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/sebastiansturm/autothemer")
+ (synopsis "Conveniently create Emacs themes")
+ (description
+ "Autothemer provides a thin layer on top of @code{deftheme} and
+@code{custom-theme-set-faces} that creates a new custom color theme, based on
+a set of simplified face specifications and a user-supplied color palette")
+ (license license:gpl3+)))
+
(define-public emacs-calfw
(package
(name "emacs-calfw")