summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-29 00:21:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-29 10:54:55 +0200
commitd79db39dec0e50720843d33d561c4606e72eb7a6 (patch)
tree9b83385a9b95533f0a092c074c414ba7a3bb824d /gnu
parente00d5b6bbf38a9d95164c07b82f615d439f2bd6a (diff)
downloadpatches-d79db39dec0e50720843d33d561c4606e72eb7a6.tar
patches-d79db39dec0e50720843d33d561c4606e72eb7a6.tar.gz
gnu: iotop: Build with python3.
* gnu/packages/linux.scm (iotop)[native-inputs]: Remove python-2, add python. [arguments]: Add phase to fix python3 compatibility.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a5564d9a90..d4624d1218 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2160,11 +2160,16 @@ the command line or a script.")
"1kp8mqg2pbxq4xzpianypadfxcsyfgwcaqgqia6h9fsq6zyh4z0s"))))
(build-system python-build-system)
(arguments
- ;; The setup.py script expects python-2.
- `(#:python ,python-2
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-with-python3
+ (lambda _
+ (substitute* "setup.py"
+ (("itervalues") "values"))
+ #t)))
;; There are currently no checks in the package.
#:tests? #f))
- (native-inputs `(("python" ,python-2)))
+ (native-inputs `(("python" ,python)))
(home-page "http://guichaz.free.fr/iotop/")
(synopsis
"Displays the IO activity of running processes")