summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-07-06 17:42:25 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-06 17:42:25 +0200
commitc2808d4c678056084412ae388031ea42898b3f6e (patch)
treeb3c4d35a73c21dd79917dfe957c022388358d98c /gnu
parent871d819965b7e183384f8973c01a95b20a5d7fca (diff)
parent8694935cc8610a775391309a83980de0e40eb53b (diff)
downloadpatches-c2808d4c678056084412ae388031ea42898b3f6e.tar
patches-c2808d4c678056084412ae388031ea42898b3f6e.tar.gz
Merge branch 'version-0.15.0'
Diffstat (limited to 'gnu')
-rw-r--r--gnu/build/vm.scm8
-rw-r--r--gnu/packages/package-management.scm8
-rw-r--r--gnu/services/base.scm9
-rw-r--r--gnu/system/examples/bare-bones.tmpl5
-rw-r--r--gnu/system/examples/desktop.tmpl8
5 files changed, 26 insertions, 12 deletions
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index abecc8c470..5579886264 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -105,7 +105,13 @@ the #:references-graphs parameter of 'derivation'."
;; hardware virtualization to still use these commands. KVM support is
;; still buggy on some ARM32 boards. Do not use it even if available.
,@(if (and (file-exists? "/dev/kvm")
- (not target-arm32?))
+ (not target-arm32?)
+
+ ;; XXX: 32-bit 'qemu-system-i386 -enable-kvm' segfaults on
+ ;; x86_64 hosts running Linux-libre 4.17:
+ ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=31380#18> and
+ ;; <https://lists.gnu.org/archive/html/qemu-devel/2018-07/msg01166.html>.
+ (not (string-suffix? "-i386" qemu)))
'("-enable-kvm")
'())
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 1c31230e58..61e203c611 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -100,9 +100,9 @@
;; Latest version of Guix, which may or may not correspond to a release.
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
- (let ((version "0.14.0")
- (commit "7af5c2a248b6c229187fc850517c84b0917c452b")
- (revision 13))
+ (let ((version "0.15.0")
+ (commit "4876bc8234095e2af191b0c6470455ce67d9f5f7")
+ (revision 1))
(package
(name "guix")
@@ -118,7 +118,7 @@
(commit commit)))
(sha256
(base32
- "06kjimcln4ydirgl05qy98kxjyx3l6brxnq1ly7wb85f73s97gix"))
+ "0qw0ffrxzxfk76pp38kx222ndpsv9mbhlmfycagyipgypgjdd9lq"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 68411439db..9fad9af99f 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1113,7 +1113,14 @@ the tty to run, among other things."
(start #~(make-forkexec-constructor
(list #$(file-append mingetty "/sbin/mingetty")
- "--noclear" #$tty
+ "--noclear"
+
+ ;; Avoiding 'vhangup' allows us to avoid 'setfont'
+ ;; errors down the path where various ioctls get
+ ;; EIO--see 'hung_up_tty_ioctl' in driver/tty/tty_io.c
+ ;; in Linux.
+ "--nohangup" #$tty
+
#$@(if auto-login
#~("--autologin" #$auto-login)
#~())
diff --git a/gnu/system/examples/bare-bones.tmpl b/gnu/system/examples/bare-bones.tmpl
index cb6d2623db..b763258e52 100644
--- a/gnu/system/examples/bare-bones.tmpl
+++ b/gnu/system/examples/bare-bones.tmpl
@@ -10,8 +10,9 @@
(timezone "Europe/Berlin")
(locale "en_US.utf8")
- ;; Assuming /dev/sdX is the target hard disk, and "my-root" is
- ;; the label of the target root file system.
+ ;; Boot in "legacy" BIOS mode, assuming /dev/sdX is the
+ ;; target hard disk, and "my-root" is the label of the target
+ ;; root file system.
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sdX")))
diff --git a/gnu/system/examples/desktop.tmpl b/gnu/system/examples/desktop.tmpl
index e8740407d0..ea21e1df66 100644
--- a/gnu/system/examples/desktop.tmpl
+++ b/gnu/system/examples/desktop.tmpl
@@ -11,11 +11,11 @@
(timezone "Europe/Paris")
(locale "en_US.utf8")
- ;; Assuming /dev/sdX is the target hard disk, and "my-root"
- ;; is the label of the target root file system.
+ ;; Use the UEFI variant of GRUB with the EFI System
+ ;; Partition mounted on /boot/efi.
(bootloader (bootloader-configuration
- (bootloader grub-bootloader)
- (target "/dev/sdX")))
+ (bootloader grub-efi-bootloader)
+ (target "/boot/efi")))
;; Specify a mapped device for the encrypted root partition.
;; The UUID is that returned by 'cryptsetup luksUUID'.