summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 15:12:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:06 +0200
commitc183fa26881d363c2c078dad534c9098e05456cd (patch)
treea7d7b53fda36b335e7b3202bed2298bae0dc37af /gnu
parent5dbe7aa92026ef7143d36036570e7e027ab85b64 (diff)
downloadpatches-c183fa26881d363c2c078dad534c9098e05456cd.tar
patches-c183fa26881d363c2c078dad534c9098e05456cd.tar.gz
gnu: Add r-officer.
* gnu/packages/cran.scm (r-officer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9d736d4d6e..a7a42573ae 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4656,6 +4656,41 @@ Rd files and roxygen2 comments, as well as many functions for manipulation of
references and Rd files.")
(license license:gpl2+)))
+(define-public r-officer
+ (package
+ (name "r-officer")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "officer" version))
+ (sha256
+ (base32
+ "14b6ii9h3fi5g8ja929mfhxps9r7x78flqjdy437y9aygkhmiz2i"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-digest" ,r-digest)
+ ("r-htmltools" ,r-htmltools)
+ ("r-magrittr" ,r-magrittr)
+ ("r-r6" ,r-r6)
+ ("r-rcpp" ,r-rcpp)
+ ("r-uuid" ,r-uuid)
+ ("r-xml2" ,r-xml2)
+ ("r-zip" ,r-zip)))
+ (home-page "https://davidgohel.github.io/officer")
+ (synopsis "Manipulation of Word and PowerPoint documents")
+ (description
+ "This package provides tools to access and manipulate Word and PowerPoint
+documents from R. The package focuses on tabular and graphical reporting from
+R; it also provides two functions that let users get document content into
+data objects. A set of functions lets add and remove images, tables and
+paragraphs of text in new or existing documents. When working with PowerPoint
+presentations, slides can be added or removed; shapes inside slides can also
+be added or removed. When working with Word documents, a cursor can be used
+to help insert or delete content at a specific location in the document.")
+ (license license:gpl3)))
+
(define-public r-writexl
(package
(name "r-writexl")