summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-01-27 14:43:46 +0100
committerAlex Kost <alezost@gmail.com>2017-01-28 12:41:35 +0300
commitba117841cdb1df618f04c7f52536a768d4bf9c2e (patch)
tree364a90263d894d888468b342b2a014b7adcbd527 /gnu
parent521f5d96f7f3bf56e43892950b5302a0b560a2d2 (diff)
downloadpatches-ba117841cdb1df618f04c7f52536a768d4bf9c2e.tar
patches-ba117841cdb1df618f04c7f52536a768d4bf9c2e.tar.gz
gnu: Add emacs-gntp.
* gnu/packages/emacs.scm (emacs-gntp): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 03de1c0684..266e45129a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3701,3 +3701,27 @@ provides functions to convert hash tables from and to alists and plists.")
"This package provides a logging framework for elisp. It allows
you to deal with multiple log levels.")
(license license:gpl3+)))
+
+(define-public emacs-gntp
+ (package
+ (name "emacs-gntp")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tekai/gntp.el/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16c1dfkia9yhl206bdhjr3b8kfvqcqr38jl5lq8qsyrrzsnmghny"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tekai/gntp.el")
+ (synopsis "Growl Notification Protocol for Emacs")
+ (description
+ "This package implements the Growl Notification Protocol GNTP
+described at @uref{http://www.growlforwindows.com/gfw/help/gntp.aspx}.
+It is incomplete as it only lets you send but not receive
+notifications.")
+ (license license:bsd-3)))