summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 20:12:59 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-04 00:10:03 +0200
commitafd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6 (patch)
treee53fe41f65e71aae9257aa37d8e1fd9ad6706439 /gnu
parent8a55e217ad3a6af96f9e05eb676616224fde509f (diff)
downloadpatches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar
patches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar.gz
Use "normalized codesets" everywhere.
In other words, change "xx_YY.UTF-8" to "xx_YY.utf8". * guix/profiles.scm (ca-certificate-bundle): Use "en_US.utf8" instead of "en_US.UTF-8". * guix/packages.scm (patch-and-repack): Likewise. * guix/build/gnu-build-system.scm (install-locale): Likewise. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Likewise. * gnu/packages/python.scm (python-ipython): Likewise. * gnu/packages/gawk.scm (gawk): Likewise. * build-aux/hydra/demo-os.scm: Likewise. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'change-locale' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gawk.scm2
-rw-r--r--gnu/packages/guile.scm30
-rw-r--r--gnu/packages/python.scm2
3 files changed, 13 insertions, 21 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index fa07f5bd4b..425974f61e 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -66,7 +66,7 @@
(setenv "GUIX_LOCPATH" (getcwd))
(zero? (system* "localedef" "--no-archive"
"--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.UTF-8")))
+ "-f" "UTF-8" "./en_US.utf8")))
%standard-phases))))
(inputs `(("libsigsegv" ,libsigsegv)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d5a95a0444..f77c9dfece 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -295,25 +295,17 @@ many readers as needed).")
(string-append "--with-guilesitedir="
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
- #:phases (alist-cons-before
- 'check 'change-locale
- (lambda _
- ;; Use the locale that's actually available in the build
- ;; environment.
- (substitute* "test/f009_form_wide.test"
- (("en_US\\.utf8")
- "en_US.UTF-8")))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/share/guile/site/"))
- (files (find-files dir ".scm")))
- (substitute* files
- (("\"libguile-ncurses\"")
- (format #f "\"~a/lib/libguile-ncurses\""
- out)))))
- %standard-phases))))
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/share/guile/site/"))
+ (files (find-files dir ".scm")))
+ (substitute* files
+ (("\"libguile-ncurses\"")
+ (format #f "\"~a/lib/libguile-ncurses\""
+ out)))))
+ %standard-phases)))
(home-page "http://www.gnu.org/software/guile-ncurses/")
(synopsis "Guile bindings to ncurses")
(description
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 708ba29d24..fd1a2d3601 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3665,7 +3665,7 @@ cluster without needing to write any wrapper code yourself.")
(man1 (string-append data "/man/man1"))
(info (string-append data "/info"))
(examples (string-append doc "/examples")))
- (setenv "LANG" "en_US.UTF-8")
+ (setenv "LANG" "en_US.utf8")
(with-directory-excursion "docs"
;; FIXME: html and pdf fail to build
;; (system* "make" "html")