summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-14 14:06:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-14 14:13:21 +0100
commit73635e3f69500dffef0d71ab5b3bbe195b6bbb9b (patch)
tree7d0b0772bd29b95390e5a7c5e6324a406f754b4e /gnu
parent6309d21579e58deee4df8c6038d332c15aa1b4d5 (diff)
downloadpatches-73635e3f69500dffef0d71ab5b3bbe195b6bbb9b.tar
patches-73635e3f69500dffef0d71ab5b3bbe195b6bbb9b.tar.gz
gnu: Add texlive-latex-changepage.
* gnu/packages/tex.scm (texlive-latex-changepage): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fcd4ffc5a0..cd3d9cc790 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4719,6 +4719,32 @@ space. If there is not enough space between the command and the bottom of the
page, a new page will be started.")
(license license:lppl)))
+(define-public texlive-latex-changepage
+ (package
+ (name "texlive-latex-changepage")
+ (version (number->string %texlive-revision))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "changepage"))
+ (sha256
+ (base32
+ "1rpw8xg5p4jsyh236jma9dz3l29wjx4062f154b3wak5yjcxyxyb"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/changepage"
+ #:tex-format "latex"))
+ (inputs
+ `(("texlive-latex-filecontents" ,texlive-latex-filecontents)))
+ (home-page "https://www.ctan.org/pkg/changepage")
+ (synopsis "Margin adjustment and detection of odd/even pages")
+ (description
+ "The package provides commands to change the page layout in the middle of
+a document, and to robustly check for typesetting on odd or even pages.
+Instructions for use are at the end of the file. The package is an extraction
+of code from the @code{memoir} class, whose user interface it shares.")
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-eukdate
(package
(name "texlive-latex-eukdate")