summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-20 00:12:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-21 17:24:27 +0200
commit27885fcc26b7f9eed37c0e587d6be00ee8bb9cb3 (patch)
treefefe278e38fbf5f0996d8a6f454f4e76367485fd /gnu
parentfdf16a81b2440964a8fc5f5e40cad84c70d165e1 (diff)
downloadpatches-27885fcc26b7f9eed37c0e587d6be00ee8bb9cb3.tar
patches-27885fcc26b7f9eed37c0e587d6be00ee8bb9cb3.tar.gz
gnu: python-pluggy: Update to 0.7.1.
* gnu/packages/python.scm (python-pluggy): Update to 0.7.1. [native-inputs]: Add PYTHON-SETUPTOOLS-SCM.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fde21d35f8..8f8aba947e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7671,15 +7671,17 @@ library as well as on the command line.")
(define-public python-pluggy
(package
(name "python-pluggy")
- (version "0.6.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pluggy" version))
(sha256
(base32
- "1zqckndfn85l1cd8pndw212zg1bq9fkg1nnj32kp2mppppsyg2kz"))))
+ "1qbn70mksmr03hac6jgp6fiqc4l7859z8dchx2x950vhlij87swm"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
(synopsis "Plugin and hook calling mechanism for Python")
(description "Pluggy is an extraction of the plugin manager as used by
Pytest but stripped of Pytest specific details.")