summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2017-12-19 12:50:00 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-21 10:44:39 +0100
commitc521c8f1a4cd50996d661c01f8ac6d4832d825f4 (patch)
treedfae0efce560ca836f122ab7cc967c410289043d /gnu
parentce16d312c6fc4d23dcf45b73709712b56d6d2174 (diff)
downloadpatches-c521c8f1a4cd50996d661c01f8ac6d4832d825f4.tar
patches-c521c8f1a4cd50996d661c01f8ac6d4832d825f4.tar.gz
gnu: Add python-tempdir.
* gnu/packages/python.scm (python-tempdir, python2-tempdir): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4baef43914..1ef54b7fd5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11974,3 +11974,30 @@ belong to tagged versions.")
"BooleanOperations provides a Python library that enables
boolean operations on paths.")
(license license:expat)))
+
+(define-public python-tempdir
+ (package
+ (name "python-tempdir")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tempdir" version))
+ (sha256
+ (base32
+ "13msyyxqbicr111a294x7fsqbkl6a31fyrqflx3q7k547gnq15k8"))))
+ (build-system python-build-system)
+ (home-page "https://pypi.org/project/tempdir/")
+ (arguments
+ ;; the package has no tests
+ '(#:tests? #f))
+ (synopsis "Python library for managing temporary directories")
+ (description
+ "This library manages temporary directories that are automatically
+deleted with all their contents when they are no longer needed. It is
+particularly convenient for use in tests.")
+ (license license:expat)))
+
+(define-public python2-tempdir
+ (package-with-python2 python-tempdir))
+