summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-09-10 04:44:25 +0200
committerBrian Leung <leungbk@mailfence.com>2019-09-20 02:20:55 +0200
commitd93e36cfa520df857a8a2bfc533c3a3b6b3c8257 (patch)
tree1de5905f1d1399c9f4a702328bbace339cc7ec93 /gnu
parentf76e4a91c25dc4441e592312a8749bd5b01ec559 (diff)
downloadpatches-d93e36cfa520df857a8a2bfc533c3a3b6b3c8257.tar
patches-d93e36cfa520df857a8a2bfc533c3a3b6b3c8257.tar.gz
gnu: Add emacs-helm-lsp.
* gnu/packages/emacs-xyz.scm (emacs-helm-lsp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f7c01999c..6a7bd69619 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16475,6 +16475,33 @@ like @code{company}, @code{flycheck}, and @code{projectile}.")
and code peeking.")
(license license:gpl3+)))
+(define-public emacs-helm-lsp
+ (let ((commit "3a58ca4cfd94b9ab1e15e819d3b16ef568e8889b")
+ (revision "1"))
+ (package
+ (name "emacs-helm-lsp")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/helm-lsp.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wh5zai3s17ss2q8wcdd6d87hv1h3nbyrxxs4js9cas8m6y2ssjv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-lsp-mode" ,emacs-lsp-mode)
+ ("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/emacs-lsp/helm-lsp")
+ (synopsis "Convert keyboard macros to Emacs Lisp")
+ (description
+ "This package displays keyboard macros or latest interactive commands
+as Emacs Lisp.")
+ (license license:gpl3+))))
+
(define-public emacs-helm-notmuch
(package
(name "emacs-helm-notmuch")