summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 17:29:42 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commitc272160ab0632a71a7de4c79442419622ecb9dfe (patch)
tree9dac2b32651051befc8d7fcb006c4e88794f21a6 /gnu
parent4af803a7c055bc1f651a6cee1c31addb1bc68aa7 (diff)
downloadpatches-c272160ab0632a71a7de4c79442419622ecb9dfe.tar
patches-c272160ab0632a71a7de4c79442419622ecb9dfe.tar.gz
gnu: Add ghc-tf-random.
* gnu/packages/haskell.scm (ghc-tf-random): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e25da78e00..088a154cb0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -479,4 +479,32 @@ library, including the ability to split random number generators.")
"This package provides various primitive memory-related operations.")
(license bsd-3)))
+(define-public ghc-tf-random
+ (package
+ (name "ghc-tf-random")
+ (version "0.5")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/tf-random/tf-random-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0445r2nns6009fmq0xbfpyv7jpzwv0snccjdg7hwj4xk4z0cwc1f"))))
+ (build-system haskell-build-system)
+ ;; these inputs are necessary to use this package
+ (propagated-inputs
+ `(("ghc-primitive" ,ghc-primitive)
+ ("ghc-random" ,ghc-random)))
+ (home-page "http://hackage.haskell.org/package/tf-random")
+ (synopsis "High-quality splittable pseudorandom number generator")
+ (description "This package contains an implementation of a high-quality
+splittable pseudorandom number generator. The generator is based on a
+cryptographic hash function built on top of the ThreeFish block cipher. See
+the paper \"Splittable Pseudorandom Number Generators Using Cryptographic
+Hashing\" by Claessen, Pałka for details and the rationale of the design.")
+ (license bsd-3)))
+
;;; haskell.scm ends here