summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-19 19:20:52 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-10-03 11:17:37 -0400
commit293ff8b2f3dc197b5350768f1ee49871069ed113 (patch)
tree7fb886b800a8e0d9057c3693c9de5e9d23a64948 /gnu
parent6f04e515604d481873205aa9e16a7c96a3cb7bd5 (diff)
downloadpatches-293ff8b2f3dc197b5350768f1ee49871069ed113.tar
patches-293ff8b2f3dc197b5350768f1ee49871069ed113.tar.gz
gnu: Add file-roller.
* gnu/packages/gnome.scm (file-roller): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b4b5c237c9..5440433402 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3625,3 +3626,36 @@ environment. It allows you to import photos from disk or camera, organize
them by keywords and events, view them in full-window or fullscreen mode, and
share them with others via social networking and more.")
(license license:lgpl2.1+)))
+
+(define-public file-roller
+ (package
+ (name "file-roller")
+ (version "3.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "04sg4yzz4c3hzgxhbgx2dc36lq5hjrnrmal2q0amfvhl0jcvp2fq"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ ;; TODO: Add libnautilus.
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("json-glib" ,json-glib)
+ ("libarchive" ,libarchive)
+ ("libnotify" ,libnotify)
+ ("nettle" ,nettle)
+ ("itstool" ,itstool)
+ ("libxml2" ,libxml2)))
+ (synopsis "Graphical archive manager for GNOME")
+ (description "File Roller is an archive manager for the GNOME desktop
+environment that allows users to view, unpack, and create compressed archives
+such as gzip tarballs.")
+ (home-page "http://fileroller.sourceforge.net/")
+ (license license:gpl2+)))