summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-27 15:20:12 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-27 15:20:12 +0530
commitdc443f5149595257780d197fcfdf07585f2e9ed2 (patch)
tree09a2a419e366ffd03614ec9b86a71cda6742de93 /gnu
parentba69e8f7ce21a81bdd5b99fdb1cc64492443e15c (diff)
downloadpatches-dc443f5149595257780d197fcfdf07585f2e9ed2.tar
patches-dc443f5149595257780d197fcfdf07585f2e9ed2.tar.gz
gnu: emacs-exwm: Fix DISPLAY environment variable issue.
* gnu/packages/emacs.scm (emacs-exwm): Set DISPLAY environment variable in shell wrapper.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a85177d814..13eba9646e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4587,9 +4587,12 @@ It should enable you to implement low-level X11 applications.")
TryExec=~@*~a~@
Type=Application~%" ,name ,synopsis exwm-executable)))
;; Add a shell wrapper to bin
+ ;; Set DISPLAY variable to work around
+ ;; https://github.com/ch11ng/exwm/issues/213
(with-output-to-file exwm-executable
(lambda _
(format #t "#!~a ~@
+ export DISPLAY=:0 ~@
~a +SI:localuser:$USER ~@
exec ~a --exit-with-session ~a \"$@\" --eval '~s' ~%"
(string-append (assoc-ref inputs "bash") "/bin/sh")