summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:16:04 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commitea92ae01c2b9f90ea169acbf4228e9cf100a35b2 (patch)
tree76fdb3f1a8bac81facc625cfbc931877e3c94b33 /gnu
parent8987d91e7fae03021e9a4e61e165f670912a2d42 (diff)
downloadpatches-ea92ae01c2b9f90ea169acbf4228e9cf100a35b2.tar
patches-ea92ae01c2b9f90ea169acbf4228e9cf100a35b2.tar.gz
gnu: Add python-fake-factory and python2-fake-factory.
* gnu/packages/python.scm (python-fake-factory, python2-fake-factory): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 50d9ee9089..7f3f95d142 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9522,3 +9522,50 @@ parsing UK postcodes.")
(define-public python2-ukpostcodeparser
(package-with-python2 python-ukpostcodeparser))
+
+(define-public python-fake-factory
+ (package
+ (name "python-fake-factory")
+ (version "0.5.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "fake-factory" version))
+ (sha256
+ (base32
+ "1chmarnrdzn4r017n8qlic0m0bbnhw04s3hkwribjvm3mqpb6pa0"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ ;; XXX: faker/tests/ne_np/__init__.py, line 40, in test_names
+ ;; first_name, last_name = name.split()
+ ;; ValueError: too many values to unpack (expected 2)
+ (lambda _
+ (delete-file "faker/tests/ne_np/__init__.py")
+ #t)))))
+ (native-inputs
+ `(("python-dateutil" ,python-dateutil-2)
+ ("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)
+ ;; For testing
+ ("python-email-validator" ,python-email-validator)
+ ("python-mock" ,python-mock)
+ ("python-ukpostcodeparser" ,python-ukpostcodeparser)))
+ (home-page "http://github.com/joke2k/faker")
+ (synopsis "Python package that generates fake data")
+ (description
+ "Faker is a Python package that generates fake data such as names,
+addresses, and phone numbers.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-fake-factory))))))
+
+(define-public python2-fake-factory
+ (let ((base (package-with-python2 (strip-python2-variant
+ python-fake-factory))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-ipaddress" ,python2-ipaddress)
+ ,@(package-native-inputs base))))))
+