summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-23 23:06:52 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 20:49:59 +0800
commit9250b0f3bf05da7e3f8b1cfaf9ce0c603ed72abf (patch)
tree313743d34ded861d41aa23e3ec6b06ab6646d46a /gnu
parent8ea8e8d3c332d2b187c26762c8e9e7930f6c2cb7 (diff)
downloadpatches-9250b0f3bf05da7e3f8b1cfaf9ce0c603ed72abf.tar
patches-9250b0f3bf05da7e3f8b1cfaf9ce0c603ed72abf.tar.gz
gnu: Add python-chai and python2-chai.
* gnu/packages/python.scm (python-chai, python2-chai): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8c34ff2e46..0c9bd22ee6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
+;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9291,3 +9292,27 @@ It supports both the original 1.0 specification, as well as the
new (proposed) 2.0 spec, which includes batch submission, keyword arguments,
etc.")
(license asl2.0)))
+
+(define-public python-chai
+ (package
+ (name "python-chai")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "chai" version))
+ (sha256
+ (base32
+ "016kf3irrclpkpvcm7q0gmkfibq7jgy30a9v73pp42bq9h9a32bl"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/agoragames/chai")
+ (synopsis "Mocking framework for Python")
+ (description
+ "Chai provides an api for mocking, stubbing and spying your python
+objects, patterned after the Mocha library for Ruby.")
+ (license bsd-3)))
+
+(define-public python2-chai
+ (package-with-python2 python-chai))
+