summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-06-22 01:52:21 -0400
committerLeo Famulari <leo@famulari.name>2016-06-22 02:38:46 -0400
commit88c8d72f3ce75e77df47dc8daaf351b1792f68e0 (patch)
tree7b09d737cba0250bbfc12aa78816ebf17c820422 /gnu
parent69af462496100a2b976a8629a135020caad04b93 (diff)
downloadpatches-88c8d72f3ce75e77df47dc8daaf351b1792f68e0.tar
patches-88c8d72f3ce75e77df47dc8daaf351b1792f68e0.tar.gz
gnu: beets: Update to 1.3.18.
* gnu/packages/patches/beets-image-test-failure.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/music.scm (beets): Update to 1.3.18. [source]: Use patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/music.scm10
-rw-r--r--gnu/packages/patches/beets-image-test-failure.patch46
3 files changed, 54 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f8d661e9b9..58f66ec878 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -442,6 +442,7 @@ dist_patch_DATA = \
%D%/packages/patches/avrdude-fix-libusb.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/bash-completion-directories.patch \
+ %D%/packages/patches/beets-image-test-failure.patch \
%D%/packages/patches/bigloo-gc-shebangs.patch \
%D%/packages/patches/binutils-ld-new-dtags.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 70757149f1..eb8bce0f6c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1474,13 +1474,17 @@ websites such as Libre.fm.")
(define-public beets
(package
(name "beets")
- (version "1.3.17")
+ (version "1.3.18")
(source (origin
(method url-fetch)
- (uri (pypi-uri name version))
+ (uri (string-append
+ "https://pypi.python.org/packages/"
+ "14/6f/c9c79c5339ab3ecced265ca18adbf5bae3d4058bae737b6164d738fb4d2c/"
+ name "-" version ".tar.gz"))
+ (patches (search-patches "beets-image-test-failure.patch"))
(sha256
(base32
- "0yg7sp18sdpszkinhb0bi6yinbn316jy1baxrwiw0m4byrj3rr6c"))))
+ "09pgyywa5llbc36y0lrr21ywgsp8m2zx6p8ncf8hxik28knd5kld"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; only Python 2 is supported
diff --git a/gnu/packages/patches/beets-image-test-failure.patch b/gnu/packages/patches/beets-image-test-failure.patch
new file mode 100644
index 0000000000..360d7d3ed4
--- /dev/null
+++ b/gnu/packages/patches/beets-image-test-failure.patch
@@ -0,0 +1,46 @@
+Fix test failure due to missing image library backend.
+
+Cherry-picked from upstream:
+https://github.com/beetbox/beets/commit/07c95a1bf16bf86c640436208dda828cc7df0181
+
+From 07c95a1bf16bf86c640436208dda828cc7df0181 Mon Sep 17 00:00:00 2001
+From: Adrian Sampson <adrian@radbox.org>
+Date: Thu, 2 Jun 2016 11:39:05 -0700
+Subject: [PATCH] Require an imaging backend for fuzzy ratio tests
+
+These fail outright if we don't have a way to get image sizes (e.g.,
+ImageMagick).
+---
+ test/test_art.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/test/test_art.py b/test/test_art.py
+index 02d26f4..1b12b76 100644
+--- a/test/test_art.py
++++ b/test/test_art.py
+@@ -561,21 +561,25 @@ def test_respect_enforce_ratio_no(self):
+ self._assertImageIsValidArt(self.IMG_500x490, True)
+
+ def test_respect_enforce_ratio_px_above(self):
++ self._require_backend()
+ self.plugin.enforce_ratio = True
+ self.plugin.margin_px = 5
+ self._assertImageIsValidArt(self.IMG_500x490, False)
+
+ def test_respect_enforce_ratio_px_below(self):
++ self._require_backend()
+ self.plugin.enforce_ratio = True
+ self.plugin.margin_px = 15
+ self._assertImageIsValidArt(self.IMG_500x490, True)
+
+ def test_respect_enforce_ratio_percent_above(self):
++ self._require_backend()
+ self.plugin.enforce_ratio = True
+ self.plugin.margin_percent = (500 - 490) / 500 * 0.5
+ self._assertImageIsValidArt(self.IMG_500x490, False)
+
+ def test_respect_enforce_ratio_percent_below(self):
++ self._require_backend()
+ self.plugin.enforce_ratio = True
+ self.plugin.margin_percent = (500 - 490) / 500 * 1.5
+ self._assertImageIsValidArt(self.IMG_500x490, True)