summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:25:57 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commitd69c4b04fafe0326c3b8185e5ca31bec5b310d3a (patch)
treee0d0a9d0d15d8541d396c22d1abb36cd3c0db458 /gnu
parentb7eee9fc65bf382a1db1bd9d6f1d6f2b92f6c62d (diff)
downloadpatches-d69c4b04fafe0326c3b8185e5ca31bec5b310d3a.tar
patches-d69c4b04fafe0326c3b8185e5ca31bec5b310d3a.tar.gz
gnu: Add r-magrittr.
* gnu/packages/statistics.scm (r-magrittr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ecd275e6e2..e8596fbd2a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -223,3 +223,25 @@ OpenSSL should be used.")
(description "The labeling package provides a range of axis labeling
algorithms.")
(license license:expat)))
+
+(define-public r-magrittr
+ (package
+ (name "r-magrittr")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/magrittr_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1s1ar6rag8m277qcqmdp02gn4awn9bdj9ax0r8s32i59mm1mki05"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/magrittr/index.html")
+ (synopsis "A forward-pipe operator for R")
+ (description
+ "Magrittr provides a mechanism for chaining commands with a new
+forward-pipe operator, %>%. This operator will forward a value, or the result
+of an expression, into the next function call/expression. There is flexible
+support for the type of right-hand side expressions. For more information,
+see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
+ (license license:expat)))