summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-14 16:52:17 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-29 22:59:28 +0100
commita665996f58764a0c6e805016915225f911294989 (patch)
tree0feb3ae24f45bd8e32d592b4e259d09027adbfbd /gnu
parentdedc8320701b3f5d23ccc213c1c0381e00b33785 (diff)
downloadpatches-a665996f58764a0c6e805016915225f911294989.tar
patches-a665996f58764a0c6e805016915225f911294989.tar.gz
gnu: python: Set SOURCE_DATE_EPOCH to 1 instead of 0.
* gnu/packages/python.scm (python-2)[arguments]: Set SOURCE_DATE_EPOCH to 1 to match what the daemon does. * guix/build/python-build-system.scm (set-SOURCE-DATE-EPOCH): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 07725c727a..7f7fa388a1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -164,7 +164,7 @@
;; Use zero as the timestamp in .pyc files so that builds are
;; deterministic. TODO: Remove it when this variable is set in
;; gnu-build-system.scm.
- (setenv "SOURCE_DATE_EPOCH" "0")
+ (setenv "SOURCE_DATE_EPOCH" "1")
#t))
(add-before
'check 'pre-check