summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorfrozenpigs <purpjuice@protonmail.com>2019-04-10 20:01:21 +0100
committerLudovic Courtès <ludo@gnu.org>2019-04-16 19:21:39 +0200
commitb8b1e4d9a2a976c4cd9933bb6a7451340f17e9ec (patch)
tree5058ceb92109ae60ce8aaf0f713706a9fbaeb371 /gnu
parent29331827325f38e441cb1af514c720f491d1bf1f (diff)
downloadpatches-b8b1e4d9a2a976c4cd9933bb6a7451340f17e9ec.tar
patches-b8b1e4d9a2a976c4cd9933bb6a7451340f17e9ec.tar.gz
gnu: Add sbcl-log4cl, cl-log4cl, and ecl-log4cl.
* gnu/packages/lisp.scm (sbcl-log4cl, cl-log4cl, ecl-log4cl): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index de2a55121b..08592bb770 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5249,3 +5249,36 @@ Python's WSGI and Ruby's Rack.")
(define-public cl-clack
(sbcl-package->cl-source-package sbcl-clack))
+
+(define-public sbcl-log4cl
+ (let ((commit "611e094458504b938d49de904eab141285328c7c")
+ (revision "1"))
+ (package
+ (name "sbcl-log4cl")
+ (build-system asdf-build-system/sbcl)
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/log4cl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08jly0s0g26b56hhpfizxsb4j0yvbh946sd205gr42dkzv8l7dsc"))))
+ ;; FIXME: tests require stefil, sbcl-hu.dwim.stefil wont work
+ (arguments
+ `(#:tests? #f))
+ (inputs `(("bordeaux-threads" ,sbcl-bordeaux-threads)))
+ (synopsis "Common Lisp logging framework, modeled after Log4J")
+ (home-page "https://github.com/7max/log4cl")
+ (description "This is a Common Lisp logging framework that can log at
+various levels and mix text with expressions.")
+ (license license:asl2.0))))
+
+(define-public cl-log4cl
+ (sbcl-package->cl-source-package sbcl-log4cl))
+
+(define-public ecl-log4cl
+ (sbcl-package->ecl-package sbcl-log4cl))