summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-06-12 16:11:51 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-06-12 16:13:16 +0200
commita9e7d6564b42cf62bab73eef3cf2bc99851ef379 (patch)
treea3809b3055ea5c36d56ff57f7f31426fd9e1f39a /gnu
parent5909bdc88735c2c1bd9f44eb6a1b518785144292 (diff)
downloadpatches-a9e7d6564b42cf62bab73eef3cf2bc99851ef379.tar
patches-a9e7d6564b42cf62bab73eef3cf2bc99851ef379.tar.gz
gnu: multipath-tools: Fix build.
(multipath-tools)[arguments]: Pass -n to gzip to avoid timestamp related warnings causing build failures.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 69c81591f1..377d46d502 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2995,7 +2995,10 @@ arrays when needed.")
(let ((lvm2 (assoc-ref inputs "lvm2"))
(udev (assoc-ref inputs "udev")))
(substitute* "Makefile.inc"
- (("\\$\\(prefix\\)/usr") "$(prefix)"))
+ (("\\$\\(prefix\\)/usr") "$(prefix)")
+ ;; Do not save timestamp to avoid gzip "timestamp
+ ;; out-of-range" warnings.
+ (("gzip -9") "gzip -9n"))
(substitute* '("kpartx/Makefile" "libmultipath/Makefile")
(("/usr/include/libdevmapper.h")
(string-append lvm2 "/include/libdevmapper.h"))