summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-15 16:16:23 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:20 +0100
commit57cd7d92d8a0206609a1ffa6609947db82b0efc6 (patch)
tree73fb977d68418addec8d65180d99515e6cf3f00e /gnu
parent073f5f20578f36022748a7692f369214ecf7363a (diff)
downloadpatches-57cd7d92d8a0206609a1ffa6609947db82b0efc6.tar
patches-57cd7d92d8a0206609a1ffa6609947db82b0efc6.tar.gz
gnu: Add ghc-tldr.
* gnu/packages/haskell.scm (ghc-tldr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8d0e2aef69..b40a5d05da 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11365,4 +11366,35 @@ embedded in your Haskell code.")
avoid the problem of partial intermediate files.")
(license license:expat)))
+(define-public ghc-tldr
+ (package
+ (name "ghc-tldr")
+ (version "0.4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tldr/tldr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nc581y9jjzwd8l88g48c72mla7k6q1w102akl7gl5jsk9ljamd3"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cmark" ,ghc-cmark)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-typed-process" ,ghc-typed-process)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)))
+ (home-page "https://github.com/psibi/tldr-hs#readme")
+ (synopsis "Haskell tldr client")
+ (description "This package provides the @command{tldr} command and a
+Haskell client library allowing users to update and view @code{tldr} pages
+from a shell. The @code{tldr} pages are a community effort to simplify the
+man pages with practical examples.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here