summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-01 22:39:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-19 10:56:47 -0400
commit13d825fcb60ada8579f8ec9663a121ab88c5fb68 (patch)
tree1161e322cd9083b2ab7445207abdfae65473b394 /gnu
parent0f0a5ef9e83242c57349223524124af077101a33 (diff)
downloadpatches-13d825fcb60ada8579f8ec9663a121ab88c5fb68.tar
patches-13d825fcb60ada8579f8ec9663a121ab88c5fb68.tar.gz
gnu: Add python-scp.
* gnu/packages/python-xyz.scm (python-scp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57b13c8263..9ac01e76c8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2649,6 +2649,29 @@ and several other projects.")
software version simply.")
(license license:expat)))
+(define-public python-scp
+ (package
+ (name "python-scp")
+ (version "0.13.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "scp" version))
+ (sha256
+ (base32
+ "1crlpw9lnn58fs1c1rmh7s7s9y5gkgpgjsqlvg9qa51kq1knx7gg"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ;tests require an SSH server
+ (propagated-inputs
+ `(("python-paramiko" ,python-paramiko)))
+ (home-page "https://github.com/jbardin/scp.py")
+ (synopsis "SCP protocol module for Python and Paramiko")
+ (description "The scp module extends the Paramiko library to send and
+receive files via the SCP1 protocol, as implemented by the OpenSSH
+@command{scp} program.")
+ (license license:gpl2+)))
+
(define-public python-rst.linker
(package
(name "python-rst.linker")